USGlobalSat GPS Forums

Please login or register.

Login with username, password and session length
Advanced search  


Pages: [1]   Go Down

Author Topic: BU-353 stopped working  (Read 1504 times)


  • Newbie
  • Karma: 0
  • Offline Offline
  • Posts: 1
BU-353 stopped working
« on: October 13, 2015, 08:39:32 am »

I have Windows 7 home prem.
I have GPSinfo.
I have a BU-353
I use it on Opncpn.
This was working fine on my windows 7 machine.
I installed it on my Ubuntu 14.04 mach using GPSD and GPSD-clients.
It worked fine.
I came back to my windows 7 machine and it does not work.
When I start GPSinfo and start the GPS the courser moves down the screen one line at a time like it
is trying to work but no data.  Just blank.
I installed the driver recommended to OmarKN (
My BU-353 still does not work.  When I plug it in sometimes (diff usb ports) the message says
"installing driver" I get a blue screen something about a zero.  It goes by very fast. 
The computer restarts and if I remove the BU-353 everything is fine except no GPS.
Sometimes I plug in the BU-353 (diff port) and it tries to work.  No blue screen. 
Then I start GPSinfo and start the GPS.  The courser drops down the screen one line
at a time like the GPS is trying to work but the lines are blank.  No info. 
The red led is blinking.
The BU-353 worked ok before but started to not work before I changed the driver.
I changed the driver in control panel manually.
It still works on the Ubuntu machine. 
I tried all three USB inputs on the windows machine and it does not work.
It seems like there is something keeping the info from being read by the computer.


  • Administrator
  • Jr. Member
  • *****
  • Karma: 0
  • Offline Offline
  • Posts: 61
Re: BU-353 stopped working
« Reply #1 on: October 27, 2015, 01:10:04 pm »

Hello Bob

When a BU-353 is connected to a Linux operating system
It converts the GPS device from NMEA to SiRF Binary because of GPSD

GPSInfo only reads NMEA

Here is the link and instructions on how to get your USGlobalSat GPS Receiver back to NMEA Protocol
1. Download and install this software:
2. Run the Sirf Demo software.
3. Connect your device, choose the correct COM port, and select the 4800 baud rate.
4. Go to Action > Open Data Source.
5. Next, go to Action > Synchronize Protocol & baud rate.
6. Then, go to Action > Switch to NMEA Protocol.
7. In the pop-up window, select the 4800 baud rate under the Baud Rate and click Send.
8. Close the Sirf Demo software.

Now, try your GPS Receiver with the GPSInfo Utility ( to see if the problem persists.

Note: Be sure and not to click on anything else in this software, as you can render your device unusable.
« Last Edit: October 27, 2015, 01:41:46 pm by USG_Tech14 »
Tech Support
Check Out Our eBay Store
Pages: [1]   Go Up

Page created in 0.191 seconds with 20 queries.