USGlobalSat GPS Forums

Please login or register.

Login with username, password and session length
Advanced search  


Pages: [1]   Go Down

Author Topic: BU-353S4 Software Initialization  (Read 1660 times)


  • Newbie
  • Karma: 0
  • Offline Offline
  • Posts: 2
BU-353S4 Software Initialization
« on: March 10, 2015, 04:59:33 pm »


Device: USGlobalSat BU-353S4

Hardware:  MacPro
Operating system: OSX 10.8.5
Programming Language: C

Mac OSX USB Driver: Version 1.5.1
GPSUtility: Version 2.10

I am working on an application to read the NMEA data from the device.

When I run the GPSUtility it obtains a fix of my current position and
the NMEA data scrolls by in the left panel.  It appears that the device
is working properly and the software driver is installed.

If I quit the GPSUtility and start my application, it reads and displays
the NMEA data.

If I run my application before running the GPSUtility it doesn't read or
display the NMEA data.

I suspect that the problem is in initializing the device.  Per the FAQ,
I have tried sending the following NMEA sentences.

4800/8/N/1 - 4800/8/N/1 - $PSRF100,1,4800,8,1,0*0E
Warm Start - $PSRF101,0,0,0,0,0,0,12,2*16
Enable WAAS/EGNOS - $PSRF151,01*0F
Enable GGA Output 1sec - $PSRF103,0,0,1,1*25
Enable GLL Output 1sec - $PSRF103,1,0,1,1*24
Enable GSA Output 5sec - $PSRF103,2,0,5,1*23

I write the sentences to the device with the checksum followed by <CR><LF>.

I check the return code after writing to the device and there is no error.

Am I missing something?  Are there any additional initialization sentences
that I should be using?


Pages: [1]   Go Up

Page created in 0.158 seconds with 20 queries.